国家漏洞库CNNVD:关于Oracle WebLogic 多个安全漏洞的通报

发布时间:2020-01-17 作者:CNNVD安全动态

近日,国家信息安全漏洞库(CNNVD)收到关于Oracle Weblogic T3协议安全漏洞(CNNVD-202001-667、CVE-2020-2546)和Oracle Weblogic WLS组件IIOP协议安全漏洞(CNNVD-202001-675、CVE-2020-2551) 情况的报送。攻击者可利用漏洞在未授权的情况下发送攻击数据,实现远程代码执行,最终控制WebLogic服务器。Oracle WebLogic Server 10.3.6.0、12.1.3.0、12.2.1.3、12.2.1.4等版本均受漏洞影响。目前,Oracle官方已经发布补丁修复了漏洞,建议用户及时确认是否受到漏洞影响,尽快采取修补措施。

一、漏洞介绍

Oracle WebLogic Server是美国甲骨文(Oracle)公司开发的一款适用于云环境和传统环境的应用服务中间件,它提供了一个现代轻型开发平台,支持应用从开发到生产的整个生命周期管理,并简化了应用的部署和管理。T3协议是用于在WebLogic服务器和其他类型的Java程序之间传输信息的协议。IIOP协议是一个用于CORBA 2.0及兼容平台,用来在CORBA对象请求代理之间交流的协议。

(1)OracleWebLogic T3协议安全漏洞(CNNVD-202001-667、CVE-2020-2546)

攻击者可以通过T3协议对存在漏洞的WebLogic Server进行反序列化攻击,成功利用该漏洞的攻击者可以对目标系统实现远程代码执行,进而控制WebLogic服务器。

(2)OracleWebLogic WLS组件IIOP协议安全漏洞(CNNVD-202001-675、CVE-2020-2551)

攻击者可以在未授权的情况下通过IIOP协议对存在漏洞的WebLogic Server组件进行反序列化攻击,成功利用该漏洞的攻击者可以对目标系统实现远程代码执行,进而控制WebLogic服务器。

二、危害影响

(1)Oracle WebLogic T3协议安全漏洞(CNNVD-202001-667、CVE-2020-2546)

成功利用该漏洞的攻击者可以对目标系统实现远程代码执行,进而控制WebLogic服务器。该漏洞涉及了多个版本,具体受影响版本如下:

Oracle WebLogic Server 10.3.6.0

Oracle WebLogic Server 12.1.3.0

(2)Oracle WebLogic WLS组件IIOP协议安全漏洞(CNNVD-202001-675、CVE-2020-2551)

成功利用该漏洞的攻击者可以对目标系统实现远程代码执行,进而控制WebLogic服务器。该漏洞涉及了多个版本,具体受影响版本如下:

Oracle WebLogic Server 10.3.6.0

Oracle WebLogic Server 12.1.3.0

Oracle WebLogic Server 12.2.1.3

Oracle WebLogic Server 12.2.1.4

三、修复建议

目前, Oracle官方已经发布补丁修复了漏洞,建议用户及时确认是否受到漏洞影响,尽快采取修补措施。Oracle官方更新链接如下:

https://www.oracle.com/security-alerts/cpujan2020.html

本通报由CNNVD技术支撑单位——奇安信科技集团股份有限公司提供支持。

CNNVD将继续跟踪上述漏洞的相关情况,及时发布相关信息。如有需要,可与CNNVD联系。

联系方式: cnnvd@itsec.gov.cn

400-622-8990